HVIS funktion i Excel

Vi viser her, hvordan HVIS funktionen bruges i betingede sætninger. Disse sætninger anvendes ofte i regneark. Ved hjælp af disse er det muligt at få regnearket til at give forskellige svar/beregninger – afhængig af indholdet af en given celle.

En betinget sætning har følgende syntaks:

=HVIS(Betingelse;Sand;Falsk)

Betingelse er en logisk matematisk test. Den skal altid kunne valideres og ende med enten sand eller falsk.

Sand og falsk. Her anføres, hvad der skal stå i cellen, hvis betingelsen er hhv. opfyldt eller ikke opfyldt. Sand og falsk kan være:

  • En formel B1 10%          Bemærk intet lighedstegn foran
  • Et tal 0
  • En tekst “Ingen rabat”     Bemærk tekst skal stå i anførselstegn

Her vises en betinget sætning, der skal beregne, om et givet køb udløser rabat eller ej. Hvis det udløser rabat, skal rabatten beregnes og påvirke feltet “I alt”. I eksemplet gives der rabat, hvis der købes for 50.000.

hvisfunktion1Den logiske test består af, om det der står i celle B1 er større end 50.000 (B1>50,000). Er dette tilfældet, så er resultatet af testen Sand og dermed beregnes rabatten til 10% af B1 (B1*10%) i modsat fald, altså hvis testen er Falsk, ydes der ingen rabat (0).

Følgende HVIS funktion skal bruges ud for Rabat B2:

=HVIS(B1>50000;B1*10%;0)

En mere kompleks HVIS formel i Excel

I mere komplekse modeller kan det være en fordel, at de værdier, der indgår i HVIS formlen, ikke tastes direkte i formlen, men i stedet i en celle som der i formlen refereres til. Det kan dermed være lettere og hurtigere at ændre en værdi ved at ændre værdien i en celle.

hvisfunktion2Du får boksen op ved at gå under fanen ”Formler”, og vælge ”fx Indsæt funktion”, vælg derefter HVIS funktionen.

Eksemplet herunder viser, hvordan celle B5 til B7 indgår i en Excel HVIS funktion.

Skærmbillede 2016-03-01 kl. 12.11.05

Excel kurser:

Skærmbillede 2016-03-01 kl. 12.11.44Vil du lære mere om den smarte HVIS funktion i Excel og andre Excel funktioner? Deltag i vores Excel-kurser og få styrket dine kompetencer. Vi tilbyder kurser over hele landet på Sjælland, Fyn og i Jylland.